10 Years Later..

jimi

Member
Joined
23 Feb 2012
Messages
90
Bucephelandra

Really? We planted it in the substrate when she set up her Edge in May and it’s been thriving. When I dug it all up to put it in her new tank yesterday it had fresh, clean looking roots on it so had no idea it needed to go on wood.

thanks for the tip :)
 

jimi

Member
Joined
23 Feb 2012
Messages
90
So I got 150 stems and got them all in the tank. I haven’t really put them in any semblance of order apart from the red ones. So it’s just a waiting game now!

59EEC24C-916E-4E66-B093-9CEFBB80E9D8.jpeg
59EEC24C-916E-4E66-B093-9CEFBB80E9D8.jpeg
56E09A6D-0F76-41BD-819E-FD9F5DF06718.jpeg
33983C6A-C9D1-4F29-830E-C6B7BF54F4BB.jpeg
0105B5A7-CE59-4168-9750-73100D507D7D.jpeg
 

jimi

Member
Joined
23 Feb 2012
Messages
90
Little update

2 cuts later. Lots of thread algae which I’m battling with everyday. Other than that it’s not too bad

29651a7bc3a4c6fd8ba65a410c707b39.jpg
7e4bd4779cc57781598f0755ef500930.jpg
911b71a6656e3b23ece764027cd03307.jpg
a9e24adbcdae3b867c4d34fc57ef2ffe.jpg



Sent from my iPhone using Tapatalk
 

Costa

Member
Joined
20 Oct 2016
Messages
354
Location
Athens, Greece
I'm also getting hair algae in my tank... Is it due to growth rate of plants being slower vs the light available?
 

jimi

Member
Joined
23 Feb 2012
Messages
90
It could be. Though I did add an extra light and have been a bit lax with the water changes so it’s probably too much phosphate. Gonna keep pulling it out and stay on top of the water changes and hopefully that will sort irZ


Sent from my iPhone using Tapatalk
 

Similar threads

Top