• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Algae in my thank, please help me.

premierpark

Seedling
Joined
18 Jul 2017
Messages
15
Location
Nagyigmánd
Hi!

There is a large amount of green algae in my aquarium.
What could be the reason?


Tank specifications - 60x40x40 - 96litre
Lighting - T5 96W - 7 hours(From 15:00 to 21:00)
CO2 - Pressurised from(From 13:00 to 21:00)
Filtration - Eheim 2075 with Seachem Matrix
Fertilisation routine - Tropica Specialized 2ml day + Tropica Premium 2ml /day

Video:
Thank you
 

kilnakorr

Member
Joined
16 Mar 2020
Messages
208
Location
Denmark
Is this a new setup?
In the video I see very little flow. Is this normal flow for the tank?
 

Nuno Gomes

Member
Joined
1 Nov 2018
Messages
156
Location
Portugal
Flow doesn't seem bad but it could be better, maybe you packed that matrix a bit too much?

Also I'd do more frequent and bigger water changes, along with manual removal of algae. I usually do 50% three times a week when I get a rough start to a setup and then switch to 50% once a week when everything is normal.
 

kilnakorr

Member
Joined
16 Mar 2020
Messages
208
Location
Denmark
Flow doesn't seem bad but it could be better, maybe you packed that matrix a bit too much?
Hard to tell, with a moving camera.
Seems good at the surface, but I can't really see it at substrate level.
Also I'd do more frequent and bigger water changes, along with manual removal of algae. I usually do 50% three times a week when I get a rough start to a setup and then switch to 50% once a week when everything is normal.
^^This!
 

Similar threads

Top