• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Aquarium issue

Bubai

New Member
Joined
8 Sep 2020
Messages
3
Location
India
I have facing the cloudy water in my tank after some day of using seachem matrix but its almost 5-6 days gone but my water not cleared up and also changed the water onces but next day it same cloudy. Now i'm found out that the inside glass have white spot type layer. So is it matrix problem or something couldn't understand
IMG_20200908_221306.jpg
IMG_20200908_221255.jpg
PLEASE SUGGEST
 

hypnogogia

Member
Joined
6 Apr 2017
Messages
648
Location
Oxfordshire
I think it’s difficult to say at the moment, without a bit of more information. Please could you provide some more information on: the length of time the tank has been set up, what filter media, other than matrix do you use, is the tank fully cycled yet, what substrate have you got?
My first thoughts are either bacterial bloom, or no fine filter floss to take out the particles causing the cloudiness.
 

Bubai

New Member
Thread starter
Joined
8 Sep 2020
Messages
3
Location
India
I just rescape the tank for a month ago ...and using a small canister filter with three types of sponge filter using flourish,excel and macro but after putting the mtrix this happend.inside my glass have the small dotted white spot
 
Similar threads
Thread starter Title Forum Replies Date
F Issue with Kh/K Water Chemistry 5

Similar threads

Top