Aquatic Magic Regulator Solenoid

PM

Member
Joined
15 Dec 2007
Messages
611
Location
London
I have one of the above, been maybe 3-4 months now, and the solenoid just gets louder and LOUDER!

This morning it sounded like a numatic drill going through a brick wall! Then I just turned the power off and on a couple of times and it became a bit more quite. Though it used to be silent, and is now still pretty loud.

Does anyone else have this problem? It's REALLY annoying having that buzzzzzz all the time! :mad:
 
Joined
10 Jun 2007
Messages
963
Location
Dorset, UK
PM said:
I have one of the above, been maybe 3-4 months now, and the solenoid just gets louder and LOUDER!

This morning it sounded like a numatic drill going through a brick wall! Then I just turned the power off and on a couple of times and it became a bit more quite. Though it used to be silent, and is now still pretty loud.

Does anyone else have this problem? It's REALLY annoying having that buzzzzzz all the time! :mad:
Ive had this problem on a few solenoids.. both that I sent back as faulty. They shouldnt buzz.
 

Dan Crawford

Founder
Staff member
Joined
21 Jun 2007
Messages
3,267
Location
Daventry, Northants
YEP! i had this issue with the same reg and sol deal from AM. I had a mare getting it sorted and gave up in the end and removed the solanoid. AM will be willing to take it back but they will want video evidence.
 

PM

Member
Joined
15 Dec 2007
Messages
611
Location
London
Here's the vid http://www.youtube.com/watch?v=ygtp8TRueV4

Does anyone have one of these from this ebay seller that DOESN'T make a noise? If so how long have you had it? If they all go like this then I'd be wasting my time and there's getting another one that will do the same after a few weeks.

How comes you gave up Matt? Were they reluctant to replace it?

Thanks
 

Dan Crawford

Founder
Staff member
Joined
21 Jun 2007
Messages
3,267
Location
Daventry, Northants
PM said:
Here's the vid http://www.youtube.com/watch?v=ygtp8TRueV4

How comes you gave up Matt? Were they reluctant to replace it?

Thanks
Na, they were happy to replace it but it was a massive faff, i wasn't in a situation to be messing about videoing, posting and arguing the toss over somthing that was below par from day one, life was easier once i removed it. My BBA when away to ;)
 

PM

Member
Joined
15 Dec 2007
Messages
611
Location
London
I just emailed them

I hate it when things go wrong, I have a stack of faulty cameras and hifi equipment too. Annoying. That buzz is winding me up! :lol:
 

LondonDragon

Administrator
Staff member
Joined
21 Feb 2008
Messages
10,911
Location
London
PM said:
I just emailed them
I hate it when things go wrong, I have a stack of faulty cameras and hifi equipment too. Annoying. That buzz is winding me up! :lol:
Take it out :p and leave CO2 on, a lot of people do, if you have many fish in there just turn on an air stone during the night until you get it sorted out ;)
 

JamesM

Member
Joined
17 Apr 2008
Messages
1,913
Location
The BIG End, South Wales
Turn off your co2 from the bottle and wait for the lines to empty, then remove the clip from the back of the solenoid taking the magnet off. You should be left with a pin that has two screws in it, remove these to see the valve and spring inside - try stretching the spring a little and lubricate it with some vaseline. Put it back together and see how she sounds :)
 

PM

Member
Joined
15 Dec 2007
Messages
611
Location
London
JAmesM said:
Turn off your co2 from the bottle and wait for the lines to empty, then remove the clip from the back of the solenoid taking the magnet off. You should be left with a pin that has two screws in it, remove these to see the valve and spring inside - try stretching the spring a little and lubricate it with some vaseline. Put it back together and see how she sounds :)
Hi, I just tried this and it worked :) though I chose not to put any vaseline in there as in my opinion it would not be a good idea. So now my solenoid is pretty much silent again :)

Ta
 
Joined
10 Jun 2007
Messages
963
Location
Dorset, UK
PM said:
JAmesM said:
Turn off your co2 from the bottle and wait for the lines to empty, then remove the clip from the back of the solenoid taking the magnet off. You should be left with a pin that has two screws in it, remove these to see the valve and spring inside - try stretching the spring a little and lubricate it with some vaseline. Put it back together and see how she sounds :)
Hi, I just tried this and it worked :) though I chose not to put any vaseline in there as in my opinion it would not be a good idea. So now my solenoid is pretty much silent again :)

Ta
thats cool :) nice one JamesM
 

PM

Member
Joined
15 Dec 2007
Messages
611
Location
London
BTW, this is only a very short term solution - mine is quite bad again, its been about a week! :(

Will have to do the same again, though I reckon the fix time will decrease, as keep stretching the spring will eventually make it weaker.
 

JamesM

Member
Joined
17 Apr 2008
Messages
1,913
Location
The BIG End, South Wales
PM said:
BTW, this is only a very short term solution - mine is quite bad again, its been about a week! :(

Will have to do the same again, though I reckon the fix time will decrease, as keep stretching the spring will eventually make it weaker.
Yup, same happened to me actually. I used a replacement spring I got from a ball point pen though. Seems much better now.
 

Similar threads

Top