balasts or flicker question

liqourish

New Member
Joined
6 Nov 2008
Messages
15
my lamp i got it used. its a 48' single florescent light. when i go to turn it on it flickers for like 5 seconds to turn on. wud this shock(as in freak out) the fishes? to fix this i need a new ballast? my smaller lamp(for 10 gallons , used as back center light :D) doesnt flicker but charges for a min and just lights on, mjuch quicker.

using a t12 florescent 6500k 40 watt bulb atm.
 

BINKSY1973

Member
Joined
13 Nov 2008
Messages
201
Location
Oxford
At a guess, i would say that the light that flicker uses a startet to light the lamp. And the lamp flickering for a few seconds at start up is normal


Your other lamp more than likely has an elctronic ballast which lights the lamp with no flicker.

Hope that helps.

Cheers Gordon.
 

GreenNeedle

Member
Joined
19 Jul 2007
Messages
2,720
Location
Lincoln UK
yep sounds right to me.

better desription of timings would tell.

A magnetic ballast with starter will mean the tube flicker starts but that should 3 or 4 filckers and last no more than a few seconds

an electronic ballast will delay for a second or less and then turn on with no flicker.

If the magnetic one is flickering a lot it may be the starter that needs replacing or the tube itself.

If the electronic one starts flickering ( I have had this once) then there may be a problem with the whole ballast.

AC
 

liqourish

New Member
Joined
6 Nov 2008
Messages
15
thanks , makes sense. wish it was electronic then lol. the flicker is annoying :/
 

Behold

Member
Joined
6 Aug 2008
Messages
219
Location
Basingstoke. Hants
liqourish said:
thanks , makes sense. wish it was electronic then lol. the flicker is annoying :/

You could replace the old ballast with an electronic one and just re use the bar and caps. the startes are then no longer an issue.
 
Similar threads
Thread starter Title Forum Replies Date
N S2 Pro dimmer question Lighting 3

Similar threads

Top