brand new eheim ecco pro 130 leaks!

Discussion in 'Filters, Filtration and Pumps' started by bazz, 21 Mar 2009.

  1. bazz

    bazz Member

    Messages:
    137
    Location:
    Lincoln
    last night i spent 3 hours swapping over filters on my 8 week old aquarium to a brand new eheim ecco pro 130 which i receiived mail order from aquatics online 2 days ago. i have had aquariums on and off (mainly on) since i was 12 (35 years) but always used internal filters, the last of which was a dennerle coc400 which ran constantly for 10 years and still works fine. however, last night after painstakingly swapping the cycled media from one of those cheapish chinese external filters off ebay and changing the tubes etc... it was ready to go. i switched it on and sat there gleefully mesmerised just watching, when after 5 minutes i noticed water starting to drip from the safety lock. i switched it off, took off the top, tipped it up and quite a lot of water ran out of every orifice of it. i repeated the process another 3 times with the filter at different heights, but the same thing happened. it is not leaking from the big red canister seal.
    i just hoped someone here might be able to help me, before i have to go through the rigmorole of having to wrap it up and post it back etc... turning an online bargain into an expensive escapade!
    cheers and thanx!
    bazz!
     
  2. rodley

    rodley Newly Registered

    Messages:
    4
    Location:
    Lot et Garonne, France
    Several things: check that no substrate has got on to the sealing rings, and then try smearing some vaseline on the rubber seals - after that????
     
  3. Nick16

    Nick16 Member

    Messages:
    1,761
    Location:
    Surrey, UK
    just to let you know, the eheim ecco is not made by eheim. it is made by a sub contractor and that is why many many people have had problems with them. poor quality.
     
  4. bazz

    bazz Member

    Messages:
    137
    Location:
    Lincoln
    thanx people, it got sent back!
     
  5. BINKSY1973

    BINKSY1973 Member

    Messages:
    201
    Location:
    Oxford
    Just out of interest are you getting a replacement for this?

    Cheers Gordon.
     
  6. bazz

    bazz Member

    Messages:
    137
    Location:
    Lincoln
    well, i was instructed to return just the sealed pump housing, (£8.00 post recorded), and after eagerly awaiting a "by return", i rang them 2 weeks later only to discover that they have no more in stock and don't know when they will. he told me he had opened it up and that there was not much in there to leak except for 3 o rings. i told him that now it had been opened that i no longer wanted it back, who knows what it might have done to the warranty, and 6 months down the line i'm sure he would have no recollection of this transaction, and asked for my money back. perhaps i'm being overly cynical, but i've been taken for a ride on more than 1 occasion. b.t.w. it cost another £5.00 to send the rest of it back, i'm just waiting to see if this postage is added to the credit note!
    cheers.
    bazz!
     

Share This Page

Facebook Page
Twitter Page
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice