• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Broken Solenoid

misscaretaker

Member
Joined
21 Aug 2008
Messages
204
Location
Basingstoke
Hiya, after dragging my CO2 system out of the garage and thinking the FE was empty it turns out (after I bought a new FE :rolleyes: ) that the solenoid is dodgy. First off it was making a terrible buzzing noise and not letting any gas through, so I took it apart and gave it all a bit of grease and after putting it back together it was quiet and working :thumbup: . However, when I unplugged it it didn't shut off so I plugged it back in and it made it's clicking noise and died... Now it does nothing when I plug it in :thumbdown: I thought about removing it but the regulator sends all the gas out of the hole where the solenoid was. I've looked for a replacement solenoid but can't find one. This is the one I bought (2 yrs ago)
140CAALSLEA.jpg


Does anyone know a) how to fix it or b) where I can get another that screws directly to to reg?
 

flygja

Member
Joined
12 Mar 2008
Messages
1,260
Location
Penang, Malaysia
Is that an Up Aqua unit? Sorry I can't help with your questions, but my colleague has one too, a bigger model with dual-regulator display. It's dodgy! It would sometimes work and sometimes won't. It's currently dead, valve won't open even when power is fed into the solenoid. He asked me to look at it, which I haven't done.

I think you're better off getting a new unit. The solenoid itself (not the regulator and needle valve) is the most expensive part of the whole unit.
 
Top