CO2 bottle / reg problem

Discussion in 'Carbon Dioxide (CO2)' started by Peter6bee, 11 Nov 2008.

  1. Peter6bee

    Peter6bee Member

    Joined:
    1 Feb 2008
    Messages:
    27
    Location:
    Wrexham
    My CO2 ran out so I went and got a refil and was given a replacement bottle.
    I've now come home and placed the reg on the new bottle, connected it all up but I cannot obtain a steady flow of bubbles.

    I set them at 1 bps but 2 mins later its either stopped or it closer to 5 bps. When it stops I slowly turn the needle valve, nothing, nothing, 5bps again. No inbetween. I've removed the reg from the bottle and put it back on again but same thing.

    I can't see how changing the bottle could effect this and sounds like a faulty regulator BUT it worked fine when it was on the last bottle.

    I am using an Aqua Medic Regulator

    [​IMG]

    Any ideas what this could be?
     
  2. Themuleous

    Themuleous Member

    Joined:
    6 Jul 2007
    Messages:
    4,126
    Location:
    Aston, Oxfordshire
    Are you using the same diffuser? If not the new one could be stopping the co2 getting out, until it reaches a v high level and which point it comes flooding out.

    Sam
     
  3. beeky

    beeky Member

    Joined:
    21 Aug 2007
    Messages:
    879
    Location:
    Chippenham, Wiltshire
    I'd try moving it much more slowly, say a few minutes between each adjustment, just so the pressure can build up to go through the diffusor.
     
  4. Peter6bee

    Peter6bee Member

    Joined:
    1 Feb 2008
    Messages:
    27
    Location:
    Wrexham
    I'm injecting it direct into the inlet of the filter which was fine before I changed the filter so no diffuser.

    I've taken the solenoid and bubble counter out of the equation too by just having a short tube going to a glass of water. Same thing happens so its nothing to do with back pressure that I can think of
     
  5. Themuleous

    Themuleous Member

    Joined:
    6 Jul 2007
    Messages:
    4,126
    Location:
    Aston, Oxfordshire
    Humm very odd. Sorry I don't think I can offer much more advice. Sounds like a problem with the reg though.

    Sam
     
  6. Amoeba

    Amoeba Member

    Joined:
    24 Mar 2008
    Messages:
    41
    Which valve do you use to adjust bps?
     
  7. Peter6bee

    Peter6bee Member

    Joined:
    1 Feb 2008
    Messages:
    27
    Location:
    Wrexham
    I was using the needle valve.

    I've had the regulator replaced now and its working fine so seems to have been a problem with that :)
    Cheers for the replies guys :D
     
  8. Themuleous

    Themuleous Member

    Joined:
    6 Jul 2007
    Messages:
    4,126
    Location:
    Aston, Oxfordshire
    Nice one :)
     

Share This Page

Facebook Page
Twitter Page
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice