EcoTech Vectra M1

Chris25

Member
Joined
14 Nov 2013
Messages
37
Location
Southampton
Hi all,

I have an EcoTech Vectra M1 and I think the o-ring is causing me issues and needs to be replaced. I can't find this anywhere online though, but I would have thought this would be something that needs replacing periodically?

I had an issue last night where the pump turned on but made a strange noise like it was struggling to start. (It did start) but then an hour or so later it turned off due to overheating.

I took it apart and the o-ring was under the rotor assembly and pushing this out from where it should sit. I removed the o-ring and plugged it back in and it ran overnight without issue. I'm not sure if by removing the o-ring it'll cause any issue or not, but I'm thinking it's safest to replace it.

Does anyone know what o-ring size I need to replace it? What material? The guides online barely mention this part.

Thanks,
Chris
 
Last edited:

zozo

Member
Joined
16 Apr 2015
Messages
7,375
Location
Netherlands
90% of standard used O-ring are synthetic rubber EPDM. I have no personal experience with these pumps. And since it is a USA product it likely uses a different standard, in Europe it's mainly DIN and ISO, also for British pipe threads. The couplers on these pumps are likely NPT.

Seeing this picture
Flexible_Installation_v2-uai-516x720.png


I would say hop into a pond shop since these ready available valve couplings might have the same o-ring that fits. I guess any well-equiped pond shop has a collection replacement o-rings in store.
018199550_1.jpg
 
Top