Product Review Eheim 1200xlt leaking

Discussion in 'Filters, Filtration and Pumps' started by SRP3006, 13 Jul 2019.

  1. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    Hi all, can somebody help with why my filter is leaking. I've checked the seals and they seem fine. Am I doing something wrong?
    I've tried attaching a video but file is too large.[​IMG]
     
  2. Keith GH

    Keith GH Member

    Messages:
    710
    Location:
    Melbourne Australia
    SRP3006
    The seals can look perfectly good but it is very possible they have aged and could have very fine cracks.

    Contact the Eheim for more information. I always used a Silicone Jell every time I cleaned the filter and never a problem. If you have to buy a seal/s make sure they are Eheim and, not a cheap copy.

    Keith:wave::wave:
     
  3. Rich C

    Rich C Newly Registered

    Messages:
    19
    Location:
    bristol
    Make sure the media baskets are sitting correctly and not overfilled stopping the pump head from sealing.
     
    Keith GH likes this.
  4. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    Do the media baskets need to be inside? I was purely checking the filter for leaks before plumbing it in, as bought it yesterday.
    Does the filter not seal correctly without the baskets?
     
  5. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    I did a quick search online for eheim support and it seems I have a eheim support centre locally. So will pop in and see what they say. Thanks.
     
  6. Rich C

    Rich C Newly Registered

    Messages:
    19
    Location:
    bristol
    Yours obviously does not so it has to be the seal,as others have said take the seal out clean it and use a bit of silicone grease when replacing.
     
  7. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    Thank you. The strange thing is that it only starts leaking when the pressure has built up and all 3 pipes are fully working. But when it starts it's quite a leak.

    I've checked the filter basket itself for leaks and that's fine. It's only when the filter is fully up and running.
     
  8. Aqua sobriquet

    Aqua sobriquet Member

    Messages:
    938
    Location:
    Dorset
    As said seals can look ok and still leak. There’s no substitute for new seals.
     
  9. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    New seals fitted and still leaking. It's not a crack as it leaks whichever way I tilt it. So therefore it's not sealed all the way. Anyone got any ideas?
     
  10. Keith GH

    Keith GH Member

    Messages:
    710
    Location:
    Melbourne Australia
    SRP

    Take the filter to the support center and see what they say.

    Keith:wave::wave:
     
  11. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    That was my next step, I just hope it's something simple.
     
  12. Keith GH

    Keith GH Member

    Messages:
    710
    Location:
    Melbourne Australia
    SRP
    There is a massive pressure once it working. Regardless I would remove all the hoses and pipes and clean them.
    Is the filter in the correct position not too low or hoses too long. All that info should be in your instruction manual, if not ask at the service center.

    There was one model that had a leak and Eheim replaced the motor head of the unit. Mine was replaced it was caused by a faulty seal in that area

    Keith:wave::wave:
     
  13. Rich C

    Rich C Newly Registered

    Messages:
    19
    Location:
    bristol
     
  14. Rich C

    Rich C Newly Registered

    Messages:
    19
    Location:
    bristol
    It does sound like the head unit is not forming a water tight seal when clipped down, i had the same probs with a jbl 1500e..i bought 4 new clips and the problem was gone,check your clips,they need to pull down quite hard.
     
    Chris Tinker likes this.
  15. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    Now u mention it I was looking at that yesterday as they don't pull down as hard as my fluval 306 that it's replacing. Obviously a cheaper option than a new head unit.
     
    Chris Tinker likes this.
  16. John S

    John S Member

    Messages:
    854
    Location:
    Welwyn Garden City
    Could be leaking from the priming area. Take the head off and then take the cover off the head to check (4 screws on the underside).
     
    dw1305 likes this.
  17. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    Checked and cleaned that area. Thanks, just taken it all apart and cleaned meticulously. Put it all back together and leaking.

    It's like the canister itself is not closing/sealing properly. Dropping of at the local service centre tomorrow for a couple of days. Maybe they can find the issue.
     
    Keith GH likes this.
  18. dw1305

    dw1305 Expert

    Messages:
    8,267
    Location:
    nr Bath
    Hi all,
    Really annoying.
    I'm not a great fan of priming buttons etc. it is just something else that can leak or break. I know you can't do it with all filters, but a quick suck on the outlet pipe is so much easier.

    That is partially why I think the <"Eheim Classic"> design is still good, water in at the bottom and out at the top, very few gaskets and not much that can go wrong. Double-taps make life a bit easier, but they aren't absolutely essential.

    All of my Eheim Classic filters were pre-owned, I've had some of them ~20 years, and they still work.

    When-ever I'm tempted by something else I remember @ceg4048 (Clive's) immortal description of an external filter as fundamentally "a pump in a bucket".

    cheers Darrel
     
    Last edited: 16 Jul 2019
    Chris Tinker likes this.
  19. SRP3006

    SRP3006 Member

    Messages:
    125
    Location:
    GB
    Took it to the support centre today. They took it apart and replaced a few more seals inside the head unit. Apparently the gasket needed replacing. But all in all they said it's leak free so hopefully sorted.
     
    Keith GH, John S and dw1305 like this.

Share This Page

Facebook Page
Twitter Page
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice