Eheim professionel II problem

Henrik

Member
Joined
16 Nov 2008
Messages
67
Location
Chester, Cheshire
My Eheim professionel II filter is leaking from the sealing area between bucket and filter head, but only if the filter is NOT running - as soon as it is on, all is fine. It seems like it needs relief fro the water pressure by having the pump 'get rid of' water...I have obviously checked and cleaned the sealing ring, but it seems perfectly ok. The closing clips are all in place as well, but they are quite easy too close, so do not seem to push much onto the seal.
I thought I ask here before potentially discarding the filter...thanks!
 

Ed Seeley

Member
Joined
3 Jul 2007
Messages
3,261
Location
Nottingham
Get in touch with Ehiem and tell them the problem. IME they have a very good after sales service. Send them an e-mail from their website.
 

BINKSY1973

Member
Joined
13 Nov 2008
Messages
201
Location
Oxford
I had the same problem with my Eheim Pro 2, i replaced the sealing ring along with some vaseline, and have never have had a problem since.


Cheers Gordon.
 

BINKSY1973

Member
Joined
13 Nov 2008
Messages
201
Location
Oxford
Henrik,

I could not se any obivous signs of damage to the sealing ring. Yes i did try vaseline and eventually got it to seal, but mine tarted to leak with the pump runnuing as well eventually. Just as well i had already ordered the sealing ring, in fact i got 2 so i have a spare now.

Cheers Gordon
 

JamesC

Member
Joined
3 Jul 2007
Messages
1,276
Location
Bexley, Kent
I had the same problem with my ageing Ehein Pro II 2028 in that it weeped slightly when I turned it off at water change time. Cured the problem by removing the seal and giving it a good coating of silicone grease and then replacing it the other way around. Hasn't leaked since.

The silicone grease I use is the same as what divers use and is much better for applying to seals than using Vaseline.

James
 

Similar threads

Top