Hi I'm new and wanted to say HI

Dave roberts

New Member
Joined
3 Mar 2020
Messages
7
Location
Shrewsbury
Hi I'm dave from Shrewsbury and just joined and wanted to say hi. I'm looking forward to learning alot from you all so I can enjoy the hobby even more.
I have a fluval Roma 125ltr
Twin star 600ea light running 100% 7.5hrs via nicrew inline dimmer
Pressurised co2 via co2 supermarket reg and neo diffuser at about 2-3 bps on 3hrs before and off 1hr before lights out
FLUVAL 306 FILTER eheim green outlet/glass skimmer inlet
HYDOR EXTERNAL 300W HEATER
EHEIM 350 SKIMMER
Tropica soil and playsand foreground
GH 12
KH 6
PH 7.5 (6.6WITH CO2 ON)
NITRATES 40ISH
TEMP 24C
I DOSE EI SCHEDULE X3 AND X3 REST SAT WATER CHANGE 60% ON SUNDAY
MY FERTS I MADE UP ARE EACH DOSE GIVES
NO3 4PPM X3
K 6PPM X3
PO4 1.3PPM X3
MG 2PPM X3
FE 0.2PPM X3
The problems I currently have are my rotala is now green used to be pink since I changed from tnc complete.
My plants always grow well at first then older leaves get covered in bba and my plants just seem as vibrant
 

Attachments

Jayefc1

Member
Joined
2 Sep 2017
Messages
1,875
Location
Swadlincote
Hi Dave and welcome nice intro and a nice tank

Are you increasing ferts as plant mass grows
Is there good flow around the older leaves that get infected
When you say grow well at first how long are we talking
Ferts seem a little low to me maybe try upping them for a couple of weeks

Is the twinstar on 100% for 7.5 hrs
Your temp is a lil hi normally we run tanks at 22 for the co2 to disolve better do you have a drop checker have you moved it around the tank to see if you have dead spots of co2

Sorry a lot of questions or things for you to think about
 

Dave roberts

New Member
Joined
3 Mar 2020
Messages
7
Location
Shrewsbury
Thanks for reply jayefc1 I have adjusted temp now to 22c and drop checker went yellow in the evening. So tweaked down a very small amount I have tried it both sides of tank and all is good. I am upping ferts a little to see one thing I have been questioning with my ph 7.5 is my iron dosing working properly its trace for apfuk many thanks.
 

Jayefc1

Member
Joined
2 Sep 2017
Messages
1,875
Location
Swadlincote
That ph does seem hi for the apfuk trace have you done a ph profile on your co2 you should be getting a drop of 1 so if your starting at 7.5 when co2 comes on it should have dropped to 6.5 by lights on the trace should be fine at 6.5 I use the same trace in all my tanks but l make it up as a all in one solution adding absordic acid to the boiled tap water to stabilise the ph at 6 in the bottle do you use distilled or tap to make your trace mix up if tap what is the ph from your tap water
 

Dave roberts

New Member
Joined
3 Mar 2020
Messages
7
Location
Shrewsbury
I will do ph profile at weekend and I actually ordered e300 e202 should be coming today and I use to water to make up ferts but I've never checked ph of it. I figured to try daily dose when tank ph is lower and hopefully uptake of iron would be better correct?? Many thanks
 

Jayefc1

Member
Joined
2 Sep 2017
Messages
1,875
Location
Swadlincote
Check the ph of your tap water and I always boil it let it cool just helps to break down the salts when its warm Potassium sorbate (E202) helps to.stop mould if your making up bigger quantities
 
Top