Plants failing :'(

mr. luke

Member
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
My moss grows fine and spreads like fire, but everything else's leaves go thin and yello, or brown at the tips and die off, but they new leaves just keep p enough to keep the plants going, if rather badly. I dose with flourish trace and some freeby ferts i have, lighing is 18w over 35l but all plants are fairly low lighting. inert substrate.
oh and for wome reason hc grows like mad in this tank?
any ideas on what is happening?
 

Themuleous

Member
Joined
6 Jul 2007
Messages
4,124
Location
Aston, Oxfordshire
We need a bit more info, like size of the tank, what kind of lighting it is (T5 or T8 and the make/model if possible), what ferts you're adding, filtration, the plants you've got. The more the better :)

My feeling at the moment is a lack of light, but the HC seems to be bucking this theory, but still possible. A photo would be useful if you are able.

Sam
 

mr. luke

Member
Thread starter
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
ill try for a photo.
the tank is roughly cube shaped by 1.5 foot ish, 35litre rena tank. filteration is a built in filter with a small but powerfull powerhead.
lighint is a pc 18w. plants are crypts, hygo, vallis and hc which does grow upwards but i trim it off so it stil carpets.
ferts are flourish trace and columbo flora grow. no c02 or liquid carbon.
 

mr. luke

Member
Thread starter
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
it is 35l lol, i didnt have a tape measure to hand so it was a rough guess, but its a small bowfronted cube shaped tank that holds 35l
 

mr. luke

Member
Thread starter
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
set up for over a year and some of the plants have been in there all this time, but others are fairly recent.
 

Dan Crawford

Founder
Staff member
Joined
21 Jun 2007
Messages
3,264
Location
Daventry, Northants
Well from what i can gather you could do with some other ferts like Tropica or the EasyLife Range and a carbon source. If you do opt for the EasyLife range then both of our sponsors have good deals on at the moment. Your lighting should be fine but thers no point in good lighting without good carbon.
HTH

Dan
 

mr. luke

Member
Thread starter
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
I hae a carbon source i could add :)
although im very wary as this tank is packed with shrimps and apple snails so i cant go overdosing on anything and have to be careful with ferts. thanks for the advice, ill get hold of some good quality ferts and see what goes on.
i have tried in the past to upgrade the lighting but it melted the hood :oops:
 

mr. luke

Member
Thread starter
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
Ok, i have started dosing at half dose, gradually building up so i can catch out any copper poisoning early. This tank means a lot to me, some of the livestock aint cheap or easy to come by :p
 

Nick16

Member
Joined
13 Aug 2008
Messages
1,769
Location
Surrey, UK
Themuleous said:
I wouldn't worry about the shrimp or snails, I've dose excel and ferts and 3x the recommended doses with no will effects :)

Sam
i dosed 2ml in my 40l of easy carbo and the same of TPN and it killed ALL the shrimp, all the cherries, amanos, everything bar the 4 whiteclouds i had.
 

Themuleous

Member
Joined
6 Jul 2007
Messages
4,124
Location
Aston, Oxfordshire
Nick16 said:
Themuleous said:
I wouldn't worry about the shrimp or snails, I've dose excel and ferts and 3x the recommended doses with no will effects :)

Sam

i dosed 2ml in my 40l of easy carbo and the same of TPN and it killed ALL the shrimp, all the cherries, amanos, everything bar the 4 whiteclouds i had.

Thats half the recommended dose, are you sure it was the TNP?

Sam
 

mr. luke

Member
Thread starter
Joined
7 Dec 2008
Messages
1,034
Location
Lincoln
I know of a fairly advanced shrimp keeper that had problems with a carbon supplement with snails and overdoses on ferts (i think) so i should be ok,
 

Similar threads

Top