Tetratec external filter leaking problems

JamesC

Member
Joined
3 Jul 2007
Messages
1,276
Location
Bexley, Kent
Just come across this about the leaking problems with the Tetratec range of external filters.

Tetra have identified a problem with this range of filters. The hose adaptor unit ball valve spindles can leak water, which then fills up the compartments within the top of the filter and then overflows down the sides of the canister. This leads the customer to think that the main canister seal is leaking, when in fact it is most unlikely.

Tetra have modified the adaptor unit and are fitting it to all new production stock

However, in the meantime, if you experiance such a leakage problem with your existing Tetra Tec EX filter, then you are advised to contact Tetra direct on 08700 55 4031 who will be happy to deal with your problem, generally at no cost to you

James
 

altaaffe

Member
Joined
13 Jul 2008
Messages
309
Location
Thornhill, Egremont, Cumbria
And here's me been ripping the mechanism apart and lubing up the seals with limited success.

Phoned them today, 60 seconds later and a replacement is on it's way. VG customer service indeed.
 

Themuleous

Member
Joined
6 Jul 2007
Messages
4,124
Location
Aston, Oxfordshire
I've not had a problem with either of mine leaking (ex600 and ex2400), but they were very very good about replacing the 2400 when it made a stupidly loud noise. And I didnt even have to return the original!

Sam
 

samc

Member
Joined
28 Oct 2008
Messages
1,381
does anyone find the ex1200 to very noisey qas i am thinking of buying one soon and its going to be in my bedroom
 

Aeropars

Member
Joined
9 Jul 2007
Messages
793
Location
Leicester
I am very disapointed. Bought a new ex600 for my nano and decided to run it on my 180l tank to get it cycled quicker. Went away for the weekend and came home to a saturated living room carpet where the filter decided to leak half the tank water out.

The missus is not impressed, and neither am I for that matter! It smells really bad so i'm having to get the carpet professionally cleaned!
 

Aeropars

Member
Joined
9 Jul 2007
Messages
793
Location
Leicester
I'm a little confused as I called that number and spoke to a chap called Rupert (that number posted is his direct dial) and he said I needed to call another number 0080076688766 which I did. I then told them my problem and that I read they had identified a problem which sounded like the problem I was having. I dont know if it was a language barrier or something but they were asking me which part was at fault! I told them I didnt know, I coudl only tell them where the water was coming from and that it was leaking out the side of the filter and you can see the water marks, to which they replied 'well, we cant send you an entire new filter'. In the end they said they would send out the part I mentioned which was on the statement at the start of this thread but after the conversations on the phone I'm not convinced this is going to fix the problem.

Did anyone else get redirected to this other number? If so, what did you say?
 

altaaffe

Member
Joined
13 Jul 2008
Messages
309
Location
Thornhill, Egremont, Cumbria
I know somebody from another site who was redirected and was put through to Germany. They sent him out a whole new head unit, which arrived damaged. After ringing back and complaining about it, he got a whole new filter sent through.

Took some perseverence & patience on his part though, with the language difficulties.
 
Joined
26 Oct 2008
Messages
1,647
Location
Cheshire
Ive had problems with my Ex1200 - intially I thought it was the outer head unit seal damaged, replaced the seal - still leaked. After several hours later the problem was the hose adaptor unit - within this unit there are two "O" rings, cleaned the "O" rings, added vasaline, ending up buying a new head unit and £20.00 lighter no further leaks. I also spoke with Tetratec asking if the could supply an "O" ring kit - 6 months later and I am still waiting for this kit. As for noise slight humming when the cupboard door is open. Other than that I cannot complain about this filter.

Regards
Paul.
 

Aeropars

Member
Joined
9 Jul 2007
Messages
793
Location
Leicester
Just thought I'd add that I had ro parts sent out to me (a hose adaptor and an O ring) both of which didnt fix the problem so Rupert had a new filter shipped out next day without needing the old one back.

I've since opened up the filter to see if i could find the problem and somewhere in the filter head its leaking water into dry chambers which are not air tight and as such these fill up and water overflow. everything looked to be ok with no cracks or gaping holes so I'm not sure where the fault lies in this instance.
 

GreenNeedle

Member
Joined
19 Jul 2007
Messages
2,720
Location
Lincoln UK
I e-mailed direct from the site to the UK rep and told him the problem. He replied to check the O rings and vaseline etc. to which I replied 'done that'.

He sent me the big O ring and the removeable in out part for free within days. Not had a problem since :)

AC
 

Simon D

Member
Joined
22 Sep 2008
Messages
460
Location
Leicestershire
I've got a new EX1200 that's not been used yet. Do you think I should go for prevention, as apposed to cure, and see if I can get the replacement parts without testing my carpet with the existing unit??

Is the problem endemic or just a few bad ones?
 

Nick16

Member
Joined
13 Aug 2008
Messages
1,761
Location
Surrey, UK
i have not had a problem with mine. it is only a few, i would run it in sitting in a large bucket and monitor it for the first couple hours.
 

Similar threads

Top