• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up

Resolved! .jpeg File extension not allowed

Ken Loach

Member
Joined
9 Mar 2017
Messages
82
Location
Merseyside
Ever since “upgrading” to iOS 11.1.2 on both my iPhone and iPad I can’t post photos to the forum. It keeps coming up with a message that the file extension .jpeg is not allowed. Try as I might to re-save photos as .jpg it has no effect and the forum still refuses the image.

Given that there are millions of Apple devices in circulation, can you change the parameters so that .jpeg files will be accepted directly from Apple devices?
 
I am the same! Funny thing is it works with a screen shot but not with photos

D6C8BB46-3F16-4D3B-A788-157DAA014451.png
 
It's in the file, not the forum.. I lately had the excact same with a few pictures send to me via Whatsapp, taken with some mobile device, no idea if it was android or iphone. Even the folder window ukaps pops up to upload didn't see this pics. It isn't in the correct extension all tho jpg is listed. I opened the pics with an image editor and saved them again as jpeg and it solved the problem. :)
 
It’s an Apple problem as I upgraded to the new iOS on my phone, before I upgraded the iPad. Forum wouldn’t accept photos from the phone but would take the same photo from the iPad which had been shared to it from the cloud.
 
Blame IOS 11 for now saving photos as jpeg rather than what it used to do and save it jpg!! I will have a look at the implications of allowing jpeg image types!
 
Thank you. As most people with iPhones will upgrade to the latest iOS and all new ones like iPhone 8 & X will come with it installed, it presents problems to a lot of people who actively participate on forums like this one.
 
Blame IOS 11 for now saving photos as jpeg rather than what it used to do and save it jpg!!

I think it's something else, i had this with a foreign recieved .jpeg, could be from an iphone the forum doesn't allow its extension. But Microsoft shows it without problems. I opened it with MSPaint saved it again as .jpeg and the forum takes it. It has the same extension as .jpeg. Properties and details of both files show the same data, i guess it must ne something in the hidden metadata. I can't read without the proper software. :)
 
No I was wrong Paulo is right.. The forum doesn't allow jpeg but allow jpg.. But both are actualy the same, the details in the image say it's a JPEG format but has a .jpg extension..

Knipsel.JPG


Knipsel1.JPG


Just Edit the file extension, delete the e from jpeg and make it ".JPG" and you should be able to upload the file. I just tried it worked. Any image viewer should still oopen the edited file because both extension don't realy differ..

Or Paulo needs to add the JPEG extension as a valid one to the forum. :)
 
Problem is you can’t change file extensions on the iPhone, you need to get them into a photo-editing program on a pc or laptop and do it there. It’s a lot of faff for a small return!
 
As of iOS 16, you can easily enable a setting in the Files app to show all file extensions on your iPhone. Here's how to do it:-
1. Open the Files app on your iPhone.
2. Navigate to any folder containing files.
3. Tap on the More icon (three dots in a circle) located in the top right corner.
4. On the menu that appears, select View Options.
5. Within the View Options, locate the Show All Extensions toggle.
6. Tap on the toggle to turn it on.
More effective instruction below.
 
Back
Top