• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Green Spot after 2 weeks of EI

Aeropars

Member
Joined
9 Jul 2007
Messages
792
Location
Leicester
Hi Guys,

I've reverted back to EI to try and revive my fortunes and after about 2 weeks I've started to see GSA.

I've made solutions as per James' website:

Potassium Nitrate (KNO3) solution - 40g to 500ml of water.
Potassium Phosphate (KH2PO4) solution - 15g to 500ml of water.

And dose 30ml and 18ml respectivly. I also added some potasium sulphate to be sure on the potassium side of things.

I'm aware one cause of green spot is to up the phosphates. Is this all I should be doing?

All help apreciated!

Lee
 

Superman

Member
Joined
29 Jan 2008
Messages
1,804
Location
Cheltenham
Recently when I stopped dosing EasyCarbo, Green Spot Algae (GSA) appeared quickly on all panes of the glass.
I upped the Phosphate and removed as much as possible then did a water change.
It's not coming back at the same rate whilst it's still there on the sides and back, I want to give my Ottos something to munch.
 

Aeropars

Member
Thread starter
Joined
9 Jul 2007
Messages
792
Location
Leicester
Thanks guys!

James, I've just added a hydor Koralia last friday so flow before this was not up to the 10x turnover needed. Now it should be in excess of this.

I wasnt aware it could be CO2 as well. I'm just waiting for my new drop checker having smased the last one while cleaning it so I'll give that a go as well.
 

Similar threads

Top