Pogostemon helferi

Steveb7

Member
Joined
20 Jul 2019
Messages
33
Location
England
  • Hi,first time on here so advice /cririsism will all be taken in. I'm new to planted aquariums after having a nano tank for a Number of yrs with easy/ standard plants in it.java crypts anubias etc.having recently got a larger tank I've tried my luck with different plants with helferi being one.this has started to brown in places as in the picture.planted in fluval stratum. Water is fine by my kit, dosing reuired amount easy carbo daily, lighting is an ehiem classic 17w for what came with the tankfor around 8hrs a day.could this be a problem.all other plants are doing fine.could it be adjusting to new tank? Co2 system will be purchased later in year we i can afford one so could this also be a problem?
    20190719_205815.jpg
 
Joined
17 Aug 2018
Messages
1,098
Location
-
Just seen you haven't recieved a response to this... how is the plant looking now? I believe it fares a lot better with co2. What size tank is it?
 

Jayefc1

Member
Joined
2 Sep 2017
Messages
2,058
Location
Swadlincote
Hi mine looks very similar co2 at around 30ppm ferts every day just hoping it's going through transition stages
Cheers
Jay
 

Steveb7

Member
Joined
20 Jul 2019
Messages
33
Location
England
Had a change around and moved into a position with better light .seems to be getting along alot better now.leaving it to get settled before giving it a trim. Added a few ferropol root tabs to my plants, along with dosing TNC probably helping aswell.co2 system should of been up and running but ordered a wrong part so that should be here in a few days.
 
Thread starter Similar threads Forum Replies Date
Mark Keetch Pogostemon Erectus issue Plant Help 4

Similar threads

Top