Airlock in Rena XP4?

Discussion in 'Filters, Filtration and Pumps' started by Tom, 10 Nov 2008.

  1. I think I must have an airlock in my XP4, as it is being very loud. Trouble is, if it is an airlock, I can't seem to get it out. I've tried shaking and tipping to filter to try and force it out the pipes, and pouring water into it using a funnel so it runs straight through the filter.

    It's really annoying me now as it's in my bedroom and it's too loud at night. Any tips on quietening it down a bit/clearing the air from it?

    Cheers,

    Tom
     
  2. Mark Evans

    Mark Evans Expert

    Messages:
    6,492
    Location:
    newark notts.
    i get the same probs with my xp 2. i fill mine through the filter inlet hole without taking klid off. do it outside and shake off the excess. connect leave for 2/3 minutes(acording to instruction) switch on. with lilly pipes you cant prime the damn thing. i think this is where the problem lies.
     
  3. Thanks Mark.

    I am using the Fluval pipes (hate the things!) as I only got the actual cannister bit of the Rena, so I can't prime it properly either.
     
  4. bugs

    bugs Member

    Messages:
    365
    Whenever my Eheim gets air trapped I switch it off, connect a syphon tube to the outlet in the tank, and suck it out. You waste a bit of water but it always works.
     

Share This Page

Facebook Page
Twitter Page
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice