HC Cuba Seeds DSM

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
It would be worth checking the thread pitch as well, I'm pretty sure the regulator will be W21.8x14, so a standard 20mm (BSP?) fitting won't work.
Yeah the Reg is W21.8
Are you sure it wont fit? :(

Would this work?
Typhoon TM22MA Brass M22 x 3/8" Male Adaptor
 
Last edited:

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
I think I'm going to give up on C02. Worked out I bought the wrong FE I got a powder one. Can't find a C02 FE in Hobart. I've seen 2kg C02 FE online but they are like $180 shipped I can't afford to pay for that every 6 months way too expensive. :( already wasted $160
 

alto

Member
Joined
24 Dec 2014
Messages
5,990
No Pubs?
No Sodastream?
Paintball?
All these CO2 gas canisters can (usually) be fit to (most) CO2 regulators
(If you got CO2Art System, contact them re adapters)
 

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
No Pubs?
No Sodastream?
Paintball?
All these CO2 gas canisters can (usually) be fit to (most) CO2 regulators
(If you got CO2Art System, contact them re adapters)
I ended up finding a cheaper supplier for FE $104 delivered got one coming. Also contacted co2art and have a M10X1 adapter coming then once the FE is done ill switch to Zip cans food grade c02 $80 for 2.2L
 

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
Hello, Tim Harrison
I'm starting to get patches where the carpet is going a dark slimey green colour do you know why this is happening mate? If you zoom in you can see it.
Maybe too much water? Not enough?
IMG_20191111_224404.jpg
 

Tim Harrison

Super Moderator
Staff member
Joined
5 Nov 2011
Messages
7,951
Location
UK
Definitely looks like plant melt. Maybe due to too much moisture, perhaps try ventilating the tank a little more and don't let the water level rise above the surface of the soil.
 

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
Definitely looks like plant melt. Maybe due to too much moisture, perhaps try ventilating the tank a little more and don't let the water level rise above the surface of the soil.
There is no build up of water at all. I haven't soaked the water even to the bottom of the soil. Open the cling wrap up a little? Can I add a air pump to get fresh C02 or will that bring the humidity down too much?
Also maybe should I dial the lights back to 10 hours they have been on constantly 12 hours for 3 weeks now.
 
Last edited:

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
Hey Tim, I've looked closely and starting to see little spider webs now too :(
Do I have to flood even though my C02 isn't setup yet?
 

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
I would wait until your CO2 is set up.

Do you think that it's a mite infestation or something similar?
I'm no expert this is my first dsm not really sure what it is. If i flood and drain I won't be able to get the water out below the soil level. I thought it was just string algae. dw1305 thinks it's fungal
 

DanosCichlids

Member
Joined
28 Oct 2019
Messages
59
Location
Tasmania
Hope I’m wrong but I reckon your seeds aren’t HC, so don’t be surprised if you are replanting in a month or 2 time :thumbdown:
They are supposed to be Glossostigma Elatinoides Hemianthus Callitrichoides (small)
Not quite sure what you are trying to accomplish there
 
Last edited:

Similar threads

Top